Add offset to community overview anchor links

by Christoph Stoettner
Read in about 1 min · 164 words

Glass Orb with Patterns

Photo by Michael Dziedzic | Unsplash

Our users are often building Highlights and Overview pages within HCL Connections Communities, where they link from one description widget to RTE or from one RTE widget to another.

We found that these anchor links often disappear behind the top navigation bar and the users wonder what happened.

The link on the left top points to an anchor link on the right side of the Overview

Now the anchor link was clicked and you see the target anchor is not visible

I created a customization file in <SHARED DIRECTORY>/customization/themes/hikariTheme/applications/communities.css with the following content:

html {
  scroll-padding-top: 250px;
}

Changed the versionStamp in LotusConnections-config.xml and restarted the application servers. Now when we click the link in Communities Overview:

Now the target anchor is visible

Community Highlights

The same offset can be seen in the Highlights App and the solution above will solve it there too.

Highlights with a link pointing to an anchor link

Link clicked with default setting

Link clicked with the deployed communities.css

Author
Add a comment
Error
There was an error sending your comment, please try again.
Thank you!
Your comment has been submitted and will be published once it has been approved.

Your email address will not be published. Required fields are marked with *

Suggested Reading
Card image cap

Today I got the question of how to disable the highlights app in Connections 7. When you follow the documentation for Connections 6.0CR6 you get an error message (and the document is not available in Connections 7).

I commented out the widget definition in widgets-config.xml like described in the documentation for the former release.

Read in about 2 min
Card image cap

Yesterday I updated a Connections environment to the latest CFix. In other environments I found that PushNotification Cluster was not started after the update, like described in the knowledge base document PushNotification broken after upgrading to CFix.65CR1.2201 . In this update the application and cluster were running, but not working at all. Browser console.log showed the error:

Error connecting to push auth sync service /servic/info: RequestError: Unable to load https://cnx-fqdn/push/service/info status: 500
Read in about 1 min
Card image cap

When I test topics with the different Connections editors (CKEditor, Textbox.io and TinyMCE), I always used multiple users in my test environment, installed the editor selector ear and then gave each of the test users a different editor. That’s easy with the different j2ee roles, but I always had to use multiple browsers or sandboxes to see them next to each other.

Read in about 2 min