Disable Highlights App in Connections 7

by Christoph Stoettner
Read in about 2 min · 288 words

Macbook Pro Keyboard

Photo by Alexander Sinn | Unsplash

Today I got the question of how to disable the highlights app in Connections 7. When you follow the documentation for Connections 6.0CR6 you get an error message (and the document is not available in Connections 7).

I commented out the widget definition in widgets-config.xml like described in the documentation for the former release.

<!-- IBM CONNECTIONS ENGAGEMENT CENTRE - ICEC4Communities  -->
<!--
<widgetDef bundleRefId="highlights" defId="Highlights" description="Highlights.description" modes="view fullpage" showInPalette="true" themes="wpthemeNarrow wpthemeWide wpthemeBanner" uniqueInstance="true" url="{webresourcesSvcRef}/../../xcc/templates/iWidgetXCCCommunityDefinition.xml">
<itemSet>
        <item name="lang" value="{lang}"/>
</itemSet>
</widgetDef>
-->
<!-- IBM CONNECTIONS ENGAGEMENT CENTRE - ICEC4Communities  -->
<templates>
        <!-- default template will be used to display the default widgets -->
        <template id="default">
                <widgetInstance defIdRef="ImportantBookmarks" instanceId="ImportantBookmarks1" uiLocation="col3"/>
                <widgetInstance defIdRef="MembersSummary" instanceId="MembersSummary1" uiLocation="col3"/>
                <widgetInstance defIdRef="StatusUpdates" instanceId="StatusUpdates1" uiLocation="col2statusposts"/>
                <widgetInstance defIdRef="description" instanceId="description1" uiLocation="col2"/>
                <widgetInstance defIdRef="Forum" instanceId="ForumInstance1" uiLocation="col2"/>
                <widgetInstance defIdRef="Bookmarks" instanceId="BookmarksInstance1" uiLocation="col2"/>
                <widgetInstance defIdRef="Files" instanceId="FilesInstance1" uiLocation="col2"/>
                <widgetInstance defIdRef="Tags" instanceId="Tags1" uiLocation="col1"/>
                <!-- <widgetInstance defIdRef="Highlights" instanceId="Highlights1" uiLocation="col1"/>-->
                <widgetInstance defIdRef="Blog" instanceId="Blog1" uiLocation="col1"/>
                <widgetInstance defIdRef="Wiki" instanceId="Wiki1" uiLocation="col1"/>
                <widgetInstance defIdRef="RichContent" ifGatekeeperSet="COMMUNITIES_TOP_MENU_WITH_BANNER_DEFAULT_LAYOUT" instanceId="RichContent1" uiLocation="banner"/>
        </template>
</templates>
  • Sychronize the nodes
  • Restart the application server hosting WidgetContainer and Communities Application
  • Now create a new community and you will get one of the following errors

Error with Community Template Wizard: Bad Request

Error with default Community create dialog: Your session timed out or a server error occurred. Please resubmit your changes

The error message does not help to find the issue, no errors are written to the SystemOut.log.

Solution

Open the Gatekeeper settings on https://YOUR_CNX_URL/connections/config/highway.main.gatekeeper.tiles and change the setting COMMUNITIES_HIGHLIGHTS_AS_OVERVIEW from True to False.

Gatekeeper Setting for COMMUNITIES_HIGHLIGHTS_AS_OVERVIEW

No need to restart an application or application server, just go back to Communities and try to create a community again. This time it works without error messages.

Author
Add a comment
Error
There was an error sending your comment, please try again.
Thank you!
Your comment has been submitted and will be published once it has been approved.

Your email address will not be published. Required fields are marked with *

Suggested Reading
Card image cap
HCL Support published a collection of links to MustGather informations for Connections and addons. That’s the perfect starting point to start troubleshooting and collecting logs for your support cases. Collecting Data: Repository of MustGather for Connections
Read in about 1 min
Card image cap

I wrote about font loading from external CDN in the post Hiding The Create Community Button 2nd last year and hoped this is finally fixed for all Connections applications. A good summary on the reasons to not allow external font loading is Blocking Web Fonts for Speed and Privacy .

So I checked with a Connections 7 deployment with the latest CFix (CFix.70.2112) deployed, if this is still an issue with Connections.

In former Connections’ versions we found external fonts loaded in Orient Me (/social), Communities Catalog (/communities) and the Admin panel (/cnxadmin/).

Read in about 5 min
Card image cap

Some time ago I got the tip from HCL Support, that the Create Community button will recognize the role community-creator only when the gatekeeper option CATALOG_CARD_UPDATED is set to false.

This is working, but I had to complain, that this option activates some code, which loads fonts from a CDN instead of the local Connections deployment.

Read in about 2 min